[QtMoko v26] online via GPRS

Marcel Meyer meyerm-om01 at fs.tum.de
Sat Sep 18 18:40:02 CEST 2010


I tried QtMoko in it's latest incarnation as the changelog said the GPRS-
handling got improved :-) . I stumbled upon the following things:

* In the chat file there is a " missing at the end of the first line. So you 
always have to edit that file by hand after you opened the settings in the 

* "on demand" does not seem to work. When I use NeronGPS and a map is missing, 
it seems as GPRS _tries_ to get online but that's all ;-)

* Staying online over a longer period of time seems to lead to a complete 
failure of the GPRS-stack so that I have to reboot the Neo to be able to get 
online again.

* Choosing "always on" leads to the phone trying to get online after booting 
and then hangs on the QtMoko-startscreen (after entering the PIN) when it 
tries to get online.

* Starting the phone without SIM does not work. After trying to switch to the 
GUI it just stays on a black screen. I tried that to prevent the phone going 

* I meanwhile managed to immediately switch to the internet settings after 
rebooting the phone (hard-reset) and deactivate the GPRS-connection before 
QtMoko managed to get online.


More information about the community mailing list