navit in QTmoko: Map don't follow actual position

Hrabosh zbynecek at
Sat Aug 6 21:23:36 CEST 2011

Hallo Frank,

is your GPSD daemon running? Is it configured properly?

If my Navit works (i.e. has current position), I can see actual
coordinates in "Action" menu below the car icon (in the middle of left

My navit.xml is attached.

BTW ... I have nothing on the screen but the map and + - icons. If you
managed to get ETA time, trip length, next turn, etc. information on the
screen, could you please share your navit.xml?

Thanks, Hrabosh 

Frank píše v Pá 05. 08. 2011 v 20:47 +0200:
> Hallo,
> I try to run navit on my freerunner.
> - QTmoko v35
> - navit Version: 0.2.0~svn3501+dfsg.1-1
> I downloaded and installed a OSM-Map for Germany.
> I see this map and can zoom and pan but ...
> My problem now is:
> The map is *not* centered on my actual position from GPS.
> I tried to configure some <vehicle>-Tags in /home/root/.navit/navit.xml
> <vehicle name=".." profilename="car" enabled="yes" active="0" 
> source="gpsd://localhost" gpsd_query="w+xj" follow="3">
> But on navit's gui I only see the default DEMO-Vehicle which has no 
> GPSD-source.
> Can someone send me an example for a working freeruner-proved 
> 'navit.xml' or a <vehicle>-Tag that follows GPS?
> How can I test, that navit gets the actual position from GPS-deamon?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: navit-xml.tar.gz
Type: application/x-compressed-tar
Size: 20450 bytes
Desc: not available
URL: <>

More information about the community mailing list