[SHR] Unable to load with Qi from uSD card (was CLEANMARKER node found [and something more I can't read] )

Martin Jansa martin.jansa at gmail.com
Sun Dec 4 18:34:07 CET 2011

On Sun, Nov 27, 2011 at 11:13:56PM +0100, ø wrote:
> > 
> > I didn't see instructions for using ubi images.
> > 
> > I have instead tried uSD card installation. I installed qi bootloader,
> > and formated a Trascend 4GB SDHC card with ext3 format, and then
> > uncompressed full-om-gta02.tar.gz file on it.
> > 
> > But when I load from qi, the card seems to not work. I have used the
> > rootdelay=5 as Qi article says, but after 5 seconds it seems not to be
> > able to read the card, and the kernel panics.
> I tried a lot of combinations, but I can't boot. This is what I get, I
> expect there aren't errors as I have typed it by hand:
> mmc1: new high speed SDHC card at address b368
> mmcblk0: mmc1:b368 USD   3.74 GiB
>  mmcblk0: unknown partition table
> Waiting 5sec before mounting root device...
> VFS: Cannot open root device "mmcblk0p1" or unknown-block(179,1)
> Please append a correct "root=" boot option; here are the available
> partitions:
> 1f00            2048 mtdblock0 (driver?)
> 1f01             256 mtdblock1 (driver?)
> 1f02             256 mtdblock2 (driver?)
> 1f03            8192 mtdblock3 (driver?)
> 1f04             640 mtdblock4 (driver?)
> 1f05             256 mtdblock5 (driver?)
> 1f06          252544 mtdblock6 (driver?)
> b300         3939112 mmcblk0  driver: mmcblk
> Kernel panic - not syncing: VFS: Unable to mount root fs on unknown
> block(179,1)

Is this with 2.6.39 and shr-core? and do you have msdos partition table
or gpt? But both are supported by 2.6.39 config and IIRC were also
enabled in 2.6.37.

> On my append-GTA02 I have:
> rootdelay=5 rootfstype=ext2 loglevel=8 quiet splash

qi built by SHR has already rootwait included in default params (instead
of rootdelay=1), what you have to do with some uSD cards is to slow down 
glamo_mci clock.

ie glamo_mci.sd_max_clk=1000000
in append-GTA02, see last comment from GNUtoo

but the clock is different for different cards ie my card works fine
with default clock and with glamo_mci.sd_max_clk=1000000 doesn't work at

GNUtoo is trying to upgrade gta kernel to resolve it..


Martin 'JaMa' Jansa     jabber: Martin.Jansa at gmail.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <http://lists.openmoko.org/pipermail/community/attachments/20111204/1ae460a7/attachment.pgp>

More information about the community mailing list