uSD corruption

Radek Polak psonek2 at
Fri Dec 16 10:08:48 CET 2011

On Thursday 15 December 2011 22:00:22 fdvjoif at wrote:

> Hi
> I have a Kingstone microSD card 8GB. It seems to be reliable for data
> but if I use it with a running distro, at this moment QtMoko, I
> experience, during a day of usage, several freezings. I mean, when it is
> in suspend mode (deep suspend enabled) if I press the power button the
> Neo does not recover from the suspend. I have to pull off the battery
> and then restart the Neo, but as can you imagine, after a couple of
> times the file system gets corrupted and I have to format the partition.
> Moreover this behaviour seems to become worse as the time passes.
> Should I consider to replace the uSD card? are there known issues in
> using running distro on it?
> Thanks.

For me uSD card never worked as stable rootfs. I always ended up with 
corrupted filesystem after a couple of days. But for data on FAT it always 
worked quite good.

I guess this is some flaw in Freerunner's hardware or kernel driver. On GTA04  
i have rootfs on uSD and no problems at all. I am starting to think that NAND 
on GTA04 is quite useless - it would be quite cool if it had 2 uSD cards 
instead (with BTRFS as fs it could rock).



More information about the community mailing list