uSD corruption

Doug Jones dj6mf at
Sat Dec 17 23:10:02 CET 2011

On 12/16/2011 01:08 AM, Radek Polak wrote:
> On Thursday 15 December 2011 22:00:22 fdvjoif at wrote:
>> Hi
>> I have a Kingstone microSD card 8GB. It seems to be reliable for data
>> but if I use it with a running distro, at this moment QtMoko, I
>> experience, during a day of usage, several freezings. I mean, when it is
>> in suspend mode (deep suspend enabled) if I press the power button the
>> Neo does not recover from the suspend. I have to pull off the battery
>> and then restart the Neo, but as can you imagine, after a couple of
>> times the file system gets corrupted and I have to format the partition.
>> Moreover this behaviour seems to become worse as the time passes.
>> Should I consider to replace the uSD card? are there known issues in
>> using running distro on it?
>> Thanks.
> For me uSD card never worked as stable rootfs. I always ended up with
> corrupted filesystem after a couple of days. But for data on FAT it always
> worked quite good.
> I guess this is some flaw in Freerunner's hardware or kernel driver. On GTA04
> i have rootfs on uSD and no problems at all. I am starting to think that NAND
> on GTA04 is quite useless - it would be quite cool if it had 2 uSD cards
> instead (with BTRFS as fs it could rock).
> Regards
> Radek

I suspect there is something about the SD card implementation that is 
deeply flawed.

To my way of thinking, an interface should be well enough defined so 
that two devices should be able to figure out how to reliably talk to 
one another after being connected for a short time, even if they were 
designed by different groups years apart.  The spec should spell out 
how, and every device should follow the spec.  If it doesn't work this 
way, then there is something wrong with the spec, or with the processes 
vendors use to implement the spec, and/or with the group that manages 
and enforces the spec.

Four years ago I discovered that some SD cards had problems with the 
OLPC XO-1.  Then I had troubles with micro SD cards in the Freerunner. 
Then I heard about problems people were having with the EEE-PC running 
Linux.  Then the SheevaPlug.  And on and on.

Four years later and I'm still hearing stories about SD cards getting 
corrupted, and you still find lists of "known to work / not work" cards 
in the wikis of various projects.  Yet, if you exclude those cards that 
have obviously failed (because they don't work properly in anything), I 
never have problems with any SD card in any camera.

What is the source of this discrepancy?  Those cameras are proprietary 
inside, but those other projects are open source.  Perhaps the people in 
charge of SD aren't revealing something to the open source communities? 
  I don't know.

There have been endless discussions over the years, about file systems, 
race conditions, suspend modes, the gravitational influence of 
Jupiter...  But I have never heard anyone claim that they actually 
understand why a card that Just Works in my camera can't be made to Just 
Work in all of our open source devices.

Yes, I know this isn't very constructive...  Sometimes I just have to 
vent...   :-)

More information about the community mailing list