[Qtmoko] automatic time?

Alfa21 freerunner at my.is.it
Fri Mar 18 19:44:40 CET 2011

2011-03-18 at 15:12 Vinzenz Hersche

> Hello all, 
> one of my biggest problems is, that my time and date will be resetet from time 
> to time. i know the solution with the hw-fix, but i didn't get time and stuff to 
> do that.
> qtmoko also got a setting "automatic" which could be set to on, off or ask.
> if i like to use the automatic time (so set to on), i always got a message : 
> "no automatic time information is currently avaible", also when it got's 
> internet. could i set anywhere a ntp-server or so to fix that? it would be nice 
> if it correct the time/date when it got internet. the calendar/todo-list would 
> be much more useable then. :)
> greets

I suggest you to install ntp on your freerunner

after that, each time there is an internet connection of any kind, your system time will be automatically synchronized with a time server.
(personally tested on usb, wifi, gprs)
it's a system daemon, so it does not consider your qtmoko's setting.

also if you do not want to hw-fix your rtc failed battery, you should set your rtc accordingly to your system time!!
assuming you have a failed rtc battery, your rtc time will be ok until you remove usb cable and you do not have power from the main battery.

so, to fix your rtc datetime, when needed, you have to:
1) log into your freerunner in SSH from another computer
2) close qtmoko program and verify no atd daemon is still running (or kill it)
3) verify your current system time is ok: date
4) synchronize rtc with system time: hwclock -w
5) verify your rtc is now ok: hwclock -r
6) reboot your moko: reboot


More information about the community mailing list