[QtMoko] landscape mode under QX

fdvjoif at vodafone.it fdvjoif at vodafone.it
Sun Sep 18 17:05:56 CEST 2011

>> For scummvm I would like to use the AUX button to access the in game
> It would be needed to disable qtmoko's AUX handling - it switches between
> application first. Then there will probably be no easy way to switch back from
> QX.

Just to try, I added

 > xmodmap -e "keycode 177 = F5"

to the script. Using ScummVM when you press the AUX button of course you 
turn back to qtmoko but when you push the "resume" button you come back 
to scummvm with the game menu opened. It's uncomfortable but it works.
But it brings to another problem: when you press AUX or receive a 
call/sms you come back to qtmoko but the screen is all messed up and it 
is difficult to take actions.
This happens only when the screen is somehow rotated. I thought that, 
because qtmoko uses framebuffer, set a rotation directly in framebuffer

 > echo 1 > /sys/class/graphics/fb0/rotate

could solve the problem but instead it produces exactly the same 
problem. So, if you rotate the screen using Xorg or framebuffer the 
QtMoko GUI becomes all messed up. I also tryed to first rotate the GUI 
(Settings-->Rotation) and then rotate the screen or to set new virtual 
size both in framebuffer and Xorg (with no success) but the result is 
the same.
I'm stuck here... :(


More information about the community mailing list