QtMoko navit wrapper script, clock stays on

Peter Fey fey.peter at googlemail.com
Sun Aug 19 18:28:26 CEST 2012

Hi all,

to automatically power on the gps in my freerunner when I start navit
(the version from http://qtmoko.sourceforge.net/apps/qtmoko-navit.html),
i renamed the file /opt/qtmoko/bin/navit to /opt/qtmoko/bin/navit.bin
and created a script file /opt/qtmoko/bin/navit as follows:


Now when I click on the navit-icon in the list of applications,after
some time, navit starts up. But the clock indicating that the system is
busy does not go away until i quit navit. The gps is powered on and
navit can read the data from gpsd.

I also tried

/opt/qtmoko/bin/navit.bin &

which does hides the clock once (I assume) the gps-poweron.sh is
finished, but has the drawback of not turning off the gps when I quit
navit and gives a subjectivley worse responsiveness of navit.

I also tried putting
in /opt/qtmoko/apps/Applications/navit.desktop and ran 
qcop QPE/DocAPI 'scanPath(QString,int)' /opt/qtmoko/apps/Applications 1
afterwards (like in the postinst script from the .deb package) to make
the change visible to qtmoko. It didn't help.

Also I tried to use a hook script in gpsd to turn on the gps once a
client (navit) connects to pull data, but that feature is not present in
the version of gpsd that comes with qtmoko.

Any help on how to get rid of the clock icon in the first script or
ideas on how to automate gps startup and shutdown is welcome.

kind regards

More information about the community mailing list