[qtmoko] charging-discharging problems

Radek Polak psonek2 at seznam.cz
Sat Aug 25 21:20:48 CEST 2012

On Saturday, August 25, 2012 06:02:40 PM Dmitry Shalnoff wrote:

> something strange happens with my Freerunner after update for new
> wersion of QtMoko (maybe it's not relevant to update). Anyway, the
> device start discharging after full charge cycle and doing this till the
> end of the battery. After that it just turn off ... or (!) if I  replug
> the power supply, it properly starts the charging cycle again.
> Is anybody have any hints? solutions?

IIRC charging was working ok for me. Btw i havent udated kernel sources so i 
doubt this is new problem.

One workaround could be to charge the phone in suspend. It will discharge very  
slowly. Not best solution but it could help at least some.

Btw i had exactly the same problem on GTA04 with very very old battery (it has 
450 charge cycles). With newer battery the problem dissapeared. Maybe you 
could also check how healthy your battery is. You can find the info under 
/sys/class/power_supply/bq-battery or something like this..

> As I know, the power control daemon turns charging and discharging on
> and off periodically. Maybe this is a cause?

Charging should be completely handled in kernel (or by the power controller 

> NB I have been trying "USB connection mode" app, I wasn't pretty sure
> that it doing anything as far it has no feedback, but maybe it relevant
> to the problem by somehow?

It probably really does nothing.



More information about the community mailing list