ubifs/NAND problem?

Boudewijn wankelwankel at yahoo.com
Mon Jan 16 00:26:48 CET 2012

On Sunday 15 January 2012 23:29:58 Boudewijn wrote:
> On Sunday 15 January 2012 22:53:24 Boudewijn wrote:
> > On Sunday 15 January 2012 21:56:04 Ivan Matveev wrote:
> > > On Sun, 15 Jan 2012 18:10:11 +0100
> > > 
> > > Boudewijn <wankelwankel at yahoo.com> wrote:
> > > > The Freerunner still won't boot from NAND though. I reflashed with
> > > > SHR-core (and SHR's ubi-qi), to no avail. After that I flashed QtMoko
> > > > v35 (and QtMoko's qi v35). 
> > > 
> > > Hi Boudewijn,
> > > I had a similar problem, couldn't boot anything from NAND(qi or uboot
> > > the same). Jffs worked fine.
> > > While trying different UBIFS distributions I have accidently flashed
> > > kernel to where bootloader should be. Reflashed everything as it should
> > > be, and the phone started to boot from NAND.
> > 
> > Thanks for the suggestion! I actually started writing as a follow-up to
> > your thread, but since you started out with v36 and ended with v35 I
> > started a new one (I started with v35 a couple of times right away)
> TL;DR:
> I overwrote my boot partition and kernel partition with useless (in this
> context) data multiple times. I expected Qi to break at some point, but it
> didn't. It also did not become "unbroken": it refuses to boot the kernel in
> Any pointer?
> Boudewijn
> PS: For now I'll start reading about u-boot on the wiki.

First achievement after downloading gena2x' u-boot to the FR: Qi is gone. 

After that, I downloaded Qi again, resulting in a booting SHR from uSD.

For now I'll focus my attention on the kernel partition; the boot loader seems 
OK. I downloaded one of the last SHR-kernels (2.6.39-xx16...), to see if 
anything happened. That's not the case: upon booting I still get SHR from uSD, 
not QtMoko with a SHR kernel and a crash after half a minute.

Lacking a crash, a boot log or anything except a running SHR, I turned back to 
u-boot, and continued following gena2x' excellent howto. Lacking a running 
environment to copy the Qi-settings from, I started off with his sample 

Now I got somewhere: using the "boot jffs from NAND" option crashed the UBI-
kernel (once again, I realize there's UBI to be had here anyway ;-) )

Just before the crash (unable to mount root fs on unknown-block(0,0) ), it 
listed the list of all partitions, with addresses (and driver? behind every 
item). With some luck, those are all jffs-driver on UBI-fs errors.

Choosing the NAND/ubi-zlib boot option, there were some warnings, I guess 
relating to running SHRs kernel on QtMoko. Anyway, QtMoko booted! 

Gennady, thank you! :-)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openmoko.org/pipermail/community/attachments/20120116/85548aaf/attachment-0001.htm>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 1967 bytes
Desc: not available
URL: <http://lists.openmoko.org/pipermail/community/attachments/20120116/85548aaf/attachment-0001.bin>

More information about the community mailing list