WLAN connection problems w. static IP

Thomas Pantzer tho.mas at pantzer.net
Sun Jun 3 13:17:12 CEST 2012


has anybody of you a working WLAN configuration
_WITH_ static IP addresses in the Neo Freerunner ?

It simply doesn't work for me or it has never been tested at all.

If I uncheck the DHCP tick and enter a static IP address in the

	Internet -> WLAN ->Properties -> IP Settings

it will be always reverted back to DHCP.

The openmoko simply doesn't use the supplied static IP address.

I can't use DHCP with my home network since my DHCP server
refuses to send IP address to clients that send too short
request.  This is another bug in the QtMoko. According to
the RFC a DHCP-request needs to be padded up to 300 chars.

Best Regards

Thomas Pantzer

More information about the community mailing list