[Gta04-owner] [QtMoko] QX touchscreen input do not work

NeilBrown neilb at suse.de
Wed Sep 12 00:48:05 CEST 2012

On Tue, 11 Sep 2012 23:33:27 +0100 Neil Jerram <neil at ossau.homelinux.net>

> Radek Polak <psonek2 at seznam.cz> writes:
> > On Monday, September 10, 2012 08:17:05 PM Neil Jerram wrote:
> >
> >> I have some theoretical patches for that (attached), but I haven't
> >> offered them to Radek because I haven't really got QX working much at
> >> all, and so I couldn't be sure if the QX rotation support was working.
> >> 
> >> The first attached patch is for the main QtMoko repository; the second
> >> is for the Arora submodule.
> >
> > Hi Neil,
> > it's applied now. I tried in arora and it works good, so i expect QX to be 
> > working too - i will try later on Freerunner.
> Great, thanks!
> > Btw has anyone figured how to rotate X server on GTA04?
> No, I don't think so.  I tried for a while before moving onto QtMoko,
> but didn't manage to understand the omapfb X driver.  And Neil Brown
> said recently that it was on his list of things he wanted to do but
> couldn't yet.

I spent a while looking into this and my conclusion is that while the frame
buffer does support rotation, the Xorg driver for the omap3 framebuffer
doesn't hook into that.  Also I couldn't find any evidence of ongoing
development of the omap3 Xorg driver.
So I'm guessing that to make 'xrandr' work on the GTA04 will take some fairly
serious hacking in Xorg driver code.

I wish I had time to do that ... though to be honest, if I did have the time
I'd probably spend it on something else :-(

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 828 bytes
Desc: not available
URL: <http://lists.openmoko.org/pipermail/community/attachments/20120912/3d0f6871/attachment.pgp>

More information about the community mailing list