QtMoko v48 neofreerunner

Neil Jerram neil at ossau.homelinux.net
Thu Sep 20 00:43:19 CEST 2012

"dmatthews.org" <mail at dmatthews.org> writes:

> Hi Neil, Radek
> I spent some time on what I believe are the email issues.
> First thing I did to ensure I'm not going mad is the flash back to
> v35. As I remembered, I can create an account without bothering with
> correct settings, put the qtopiamail.conf in place and everything
> works.
> Next I flashed the 2nd v48 image - the situation has improved - the
> problem with the "Get all mail" entry disappearing has ... well
> disappeared - it does work fine. Despite what you thought - a
> difference in v48-1 with the upgraded qtmoko package installed on top
> as against the good v48-2? Can't be sure, but at least it's gone away
> for me.

Well that's good news!

> Trying to send mail though, that problem is as I reported already; I'm
> using the same qtopiamail.conf I just used in v35 which specifies the
> fastmail SMTP server (which I can ping) - sending a test mail to
> myself at dmatthews.org gives this rather generic looking error:-
> dmatthews.org -Error sending
> Email:Error occurred
> [Unknown error]

That comes from EmailClient::transferFailure() in
src/applications/qtmail/emailclient.cpp.  Tracking back from there, I

- EmailClient::activityChanged(QMailServiceAction::Failed)

- QMailTransmitAction::activityChanged(QMailServiceAction::Failed)

- QMailServiceActionPrivate::emitChanges() following something that set
  _activityChanged to TRUE

- QMailServiceActionPrivate::setActivity(QMailServiceAction::Failed)
  (which is the only place that sets _activityChanged to TRUE)

- QMailServiceActionPrivate::errorOccurred() or
  (QMailTransmitActionPrivate::sendCompleted with !_ids.isEmpty()).

More likely errorOccurred, I guess.  That's as far as I can get for now;
the next step seems to involve a QtopiaIpcAdaptor, which I'm not
familiar with.

However, I think that point is not far above the raw SMTP level, so I
wonder if it would help to enable SMTP logging and see what that shows?
To do that, go into Home, Settings, Logging; choose YES twice; then
choose "Categories..." from the context menu, and check SMTP; then back
all the way out.  (You don't need to restart QtMoko, despite what it

Then repro the sending error.  Then go back into Logging and see what it

With fingers crossed,


More information about the community mailing list