Problems using recent Rogers Wireless (Canada) SIMs in GTA02

Pascal Gosselin pascal at
Thu Sep 27 03:53:14 CEST 2012

In 2010, we were able to take circa mid-2008 Roger Wireless SIMs 
(Canada) borrowed from an iPhone 3G and get it to work in Android Froyo 
on the GTA02 850Mhz.

Two years later, we decided to add some GPRS reporting capability to our 
Wi-Flight product which is currently using Wi-Fi only, we are unable to 
get a carrier registration at the AT command level using two Rogers SIMs 
(both from 2012, one used in an iPhone 4 and the other in a Samsung 
Galaxy S II Skyrocket (LTE)).  The GSM baseband code was at Moko8 so we 
had the  fix for bug 666.  We tried Moko11 but it didn't make a difference.

We repeated the same Android Froyo setup and indeed it doesn't work when 
we try the circa 2012 SIMs.

Our product doesn't run on Android, the Froyo stuff was just tried to 
attempt to replicate something that worked before.

I found a working older Rogers full-sized SIM from my GSM-enabled alarm 
system, which I think it at least 3-4 years old.  It worked just fine in 
a Nexus S and I was able to send an SMS and Edge data from the phone 
(it's a T-mobile AWS phone so no 3G on Rogers).

The conclusion so far is that something has changed in the Rogers SIMs 
that makes it incompatible with the GTA02.  I am wondering if anyone 
else has encountered this problem.  I'd be happy to be able to get a 
Fido-branded card to work (haven't tried that yet).

We've repeated the same issue with a half-dozen GTA02s so we're pretty 
sure it's not a one-off phone problem.

Pascal Gosselin
pascal at
cell (514) 298-3343
office (450) 676-6299

More information about the community mailing list