Qtmoko v52-armhf : Issue to resume

Adrien Dorsaz adrien at adorsaz.ch
Tue Feb 12 07:58:43 CET 2013


Le vendredi 08 février 2013 à 17:37 +0100, Radek Polak a écrit :
> On Friday, February 08, 2013 04:08:06 PM Adrien Dorsaz wrote:
> > Hello!
> > 
> > I've noticed two issues when I resume my phone from suspend :
> > 
> >       * Sometimes my screen kept black and I'm only able to shut down my
> >         phone with power button (I didn't have my computer at these
> >         times, so I don't know if I was able to connect with ssh)
> >       * Sometimes the screen display the last qtmoko image with screen
> >         lock, but it's stuck. Eg, now my screen dipslays 2pm (last
> >         suspend I think), but here I'm at 3 pm now. The only one
> >         interaction possible is to press Aux and see the "^@" strings
> >         displayed.
> Hmm i guess we need to reproduce it somehow. Maybe automatic suspend resume 
> cycles using rtc alarm could reproduce it - but IIRC i tried it and had no 
> luck.

I didn't have this issue since some days, but it appeared this morning
again, after this situation :
      * I'v made a call in the train
      * An interruption appeared because the swiss gsm network in trains
        is really bad
      * So my correspondant called me back (she was in another train),
        but I wasn't able to answer (I'm pretty sure it's because of our
        gsm network again, we had same errors using proprietary phones)
      * Finally I've called her again and we were able to finish our
        discussion normally.

Furthermore, after each call end, I receive an SMS from my gsm operator
to say me how many credits I've on my SIM card.

That's not really easy to reproduce...

I've straced again qpe process and I've seen same error with (Q)Debus.
So I've stopped qtmoko-gta04 service, then I've restarted dbus service
and started qtmoko-gta04 service again and all works fine.

I didn't think to strace dbus process, so it's not really relevant, but
this workaround seems to work.

I hope to have this bug again to be able to produce more straces.

See you,

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <http://lists.openmoko.org/pipermail/community/attachments/20130212/8d34bdb5/attachment.pgp>

More information about the community mailing list