GTA02 boot without screen

Benjamin Deering ben_deering at
Mon Jan 7 13:52:25 CET 2013

On 01/02/2013 05:41 PM, Benjamin Deering wrote:
> On 01/02/2013 08:45 AM, rhn wrote:
>> On Wednesday 02 of January 2013 07:30:44 Benjamin Deering wrote:
>>> My gta02, or possibly the bare board I removed to convert my GTA04 is
>>> getting a new job as a wifi audio forwarder to let me play music 
>>> over my
>>> hifi wirelessly.  I would like to remove the battery from this phone
>>> once it is set up to prevent damage to the battery and to free up
>>> another battery for long trips.
>>> Both of my GTA02s are A5 with buzzfix.  It sounds like A7 had a change
>>> to allow it to boot without a battery.  Does anyone know what the 
>>> change
>>> is and if it is something I could apply myself?   I am going to be 
>>> doing
>>> the bass-fix and it would be nice to fix this at the same time.
>>> Thanks,
>>> Ben
>> Hi Ben,
>> I'm interested in how you got the board to boot and be accessible 
>> from outside without a screen.
>> Some time ago my GTA02 was dunked in water and that broke its screen. 
>> After reflashing SHR, I wasn't able to access it in any way because 
>> the screen was required to finish setup.
>> What distribution did you use?
>> Cheers,
>> rhn
>> P.S. If anyone's interested in the device, feel free to contact me.
> I haven't tried my bare board yet.  My plan was to get wifi, avahi, 
> and pulseaudio all starting automatically on the complete phone, then 
> try the SD card in the bare board.
I spent some time on this over the weekend.  The bare board boots fine 
without a screen.  I got impatient waiting for the parts for my 
capacitance meter and scavenged some electrolytic caps since they are 
labeled.  The worked fine for the bass fix.  I didn't bother to put the 
shielding back on since I won't be using GSM.

I am still unable to boot without battery.  Repeated plugging and 
unplugging the usb occasionally starts to boot, but I get only a single 
LED flash (kernel doesn't load).  Should I switch to a bigger cap?  I am 
a software engineer.  I shouldn't even be allowed to wield a soldering iron.

  I was also unable to avoid ordering an A1200 headset adapter.  I 
couldn't find a way to fool the internal switches in the jack to let me 
solder a 3.5mm jack to a lead.

Is there a reason electrolytic caps are a bad idea for these applications?

Robin: I probably won't be documenting this other than on the mailing 
list.  My software is such an ugly hack as is the hardware.  I had 
trouble powering up wifi from systemd so my wifi script kills a bunch of 
processes and turns on the radio from sysfs.

>> _______________________________________________
>> Openmoko community mailing list
>> community at
> _______________________________________________
> Openmoko community mailing list
> community at

More information about the community mailing list