QtMoko and X applicatiions

Dr. H. Nikolaus Schaller hns at goldelico.com
Wed Jan 30 09:43:08 CET 2013


Am 30.01.2013 um 09:22 schrieb Timo Juhani Lindfors:

> "Dr. H. Nikolaus Schaller" <hns at goldelico.com> writes:
>>> wget http://lindi.iki.fi/lindi/tslib/libts-0.0-0_1.0-8lindi1_armel.deb
>>> dpkg -i libts-0.0-0_1.0-8lindi1_armel.deb
> That package can disappear any time. It was only offered to triage a bug

I have made a copy where it will be as long as the GTA04 project exists:


> in
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=623095
> I'm really puzzled that you are actually using it in a distribution. How
> about using tslib 1.0-9 instead?

Well, it is the usual fragmentation of information problem :)

I did not know that there is an issue - until I tried to use the official
squeeze tslib with a 3.7 kernel yesterday.

I didn't know and find solutions (I do neither read the freerunner IRC
nor remember things so long) except tracking down the issue and
compiling the tslib myself.

Then, Radek did hint at his solution to use your (old) version
(which just does its job very well).

Now, there is the next piece of info that it is itself old...

My general idea is that the gta04 project collects
all these pieces and provides a rock solid debian stable
basis that simply works - but without a specific GUI.

And different GUI systems/distributions don't have to care
about it too much. Ideally all of them should be installable
as easily as

apt-get install lxde

and removed by

apt-get remove lxde

based on some "official" GTA04 debian base image.

But to make this work, it might need a little more consolidation
of what we already have.

And better reporting of issues/solutions to the central repository.
So please use the "issues" reporter:


or more specific for the "debian stable" rootfs:


>> apt-get source libts-0.0-0
>> sed -i s/0x010000/0x010001/g /usr/include/linux/input.h
>> ( cd tslib-1.0 && dpkg-buildpackage -uc -b )
>> sed -i s/0x010001/0x010000/g /usr/include/linux/input.h
>> dpkg -i libts-0.0-0_1.0-7_armel.deb
>> but certainly needs more time than wget :)
> Or
> dget -x http://lindi.iki.fi/lindi/tslib/tslib_1.0-8lindi1.dsc
> pbuilder --build tslib_1.0-8lindi1.dsc

BR and thanks to all for your great work (I could base mine on),

More information about the community mailing list