[QtMoko] WPA connections workaround

francesco.devita at mailoo.org francesco.devita at mailoo.org
Mon Sep 30 12:36:30 CEST 2013

There is an annoying problem in QtMoko when you try to connect to a WPA
protected network: the network manager fails to connect to the chosen
network and/or loses manual IP settings.
I don't remember if this issue was solved but I found a workaround by
chance. I noticed that if there is only and only one network around you
and if you manually sets your IP, then the connection successfully happens.
Instead, when there are a lot of networks, the aforementioned issue occurs.
This is the workaround I found:
- scan for the networks
- go to the network manager properties and select the second voice
"Wireless Settings"
- on top, there is a dropdown list of nearby networks, delete all of
them but the network you want to connect to
- go back and choose "IP settings" and set IP manually (this is mandatory)
- go back to the network manager main page, open up the option menu and
enable the connection.

I tested this "procedure" with QtMoko v55 and v56, only with two
different networks, but it is the only way for me to have a working
connection. IIRC there are no problems at all in connecting to open
Hope it could be useful.


More information about the community mailing list