TIFFS in vitro analyzer tool released

Michael Spacefalcon msokolov at ivan.Harhan.ORG
Tue Feb 4 18:37:49 CET 2014

Giacomo 'giotti' Mariani <giacomomariani at yahoo.it> wrote:

> It's been easier than expected:
> root at neo:~# . /opt/qtmoko/qpe.env
> root at neo:/root# /etc/init.d/qtmoko-neo stop
> root at neo:/mnt/nfs/root/ModemFFS/Backup# fc-loadtool -h gta02 /dev/ttySAC0
> [...]
> root at neo:/mnt/nfs/root/ModemFFS/Backup# /etc/init.d/qtmoko-neo start

Nice. :-)

> Now I'm looking at it with mokoffs :-)

Because my sample size so far has been 1, I would like to know how the
FFS content on other FR units differs from mine.  I would appreciate
it if you could do a mokoffs xtr on your FFS image, then do the same
on the image from my FR (from my FTP site, URL posted earlier), and
then let me know what diff -r between the two extracted trees shows.

David Matthews <mail at dmatthews.org> wrote:

> That's interesting - and it worked without a cacophony as accompaniment?

I repeat: if one does not do
'echo 1 > /sys/bus/platform/devices/gta02-pm-gsm.0/download'
which is not necessary when running loadtools from the AP (but is
necessary for the cable method), then the cacophony cannot occur.

> I just tried to confirm this myself; using the cable method it does not work
> for me on Qtmoko 54. I had the same problem using SHR and following the
> instructions that Norayr posted, but again using a cable rather than running
> loadtools on the phone as he did.

Have you ever tried troubleshooting it like I suggested earlier?  I.e.,
take loadtools out of the equation for a moment, run a standard
terminal emulator program like minicom on the PC end of the cable, then
try echo'ing '1' and '0' into the 'power_on' node in sysfs and see if
the RVT output appears/disappears in response?


More information about the community mailing list