<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
<body bgcolor="#ffffff" text="#000000">
Henryk Pl&ouml;tz wrote:<br>
<blockquote cite="mid:20070728185434.569c7acd.henryk@openmoko.org"
  <pre wrap=""><!---->
Please post the full error message that the qemu configure gives.
Here is the output of configure:<br>
white-rabbit qemu-neo1973 # ./configure <br>
WARNING: "gcc" looks like gcc 4.x<br>
Looking for gcc 3.x<br>
Found "gcc32"<br>
Install prefix&nbsp;&nbsp;&nbsp; /usr/local<br>
BIOS directory&nbsp;&nbsp;&nbsp; /usr/local/share/qemu<br>
binary directory&nbsp; /usr/local/bin<br>
Manual directory&nbsp; /usr/local/share/man<br>
ELF interp prefix /usr/gnemul/qemu-%M<br>
Source path&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; /usr/src/qemu-neo1973<br>
C compiler&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; gcc32<br>
Host C compiler&nbsp;&nbsp; gcc<br>
make&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; make<br>
install&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; install<br>
host CPU&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; x86_64<br>
host big endian&nbsp;&nbsp; no<br>
target list&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; i386-linux-user arm-linux-user armeb-linux-user
sparc-linux-user ppc-linux-user mips-linux-user mipsel-linux-user
m68k-linux-user alpha-linux-user i386-softmmu ppc-softmmu sparc-softmmu
x86_64-softmmu mips-softmmu mipsel-softmmu mips64-softmmu
mips64el-softmmu arm-softmmu ppc64-softmmu ppcemb-softmmu m68k-softmmu<br>
gprof enabled&nbsp;&nbsp;&nbsp;&nbsp; no<br>
profiler&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; no<br>
static build&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; no<br>
SDL support&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; no<br>
mingw32 support&nbsp;&nbsp; no<br>
Adlib support&nbsp;&nbsp;&nbsp;&nbsp; no<br>
CoreAudio support no<br>
ALSA support&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; no<br>
DSound support&nbsp;&nbsp;&nbsp; no<br>
FMOD support&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; no <br>
OSS support&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; yes<br>
kqemu support&nbsp;&nbsp;&nbsp;&nbsp; yes<br>
Documentation&nbsp;&nbsp;&nbsp;&nbsp; no<br>
ERROR: QEMU requires SDL or Cocoa for graphical output<br>
To build QEMU without graphical output configure with
Note that this will disable all output from the virtual graphics card.<br>
<blockquote cite="mid:20070728185434.569c7acd.henryk@openmoko.org"
  <pre wrap="">

There is another much more likely problem with gentoo x86_64 and qemu:
qemu needs a gcc 3.x, while Gentoo by default now is at 4.x. One has to
emerge an additional 3.x series gcc (3.4.6* is current in Gentoo) and
either edit the MokoMakefile (add --cc=gcc-3.4.6 to the qemu-configure
call, after --target-list=arm-softmmu) or the qemu-configure (add
gcc-3.4.6 to gcc3_list).

Ok, I'll try setting it to gcc3.4.6 which is still on my system and see
if that helps.&nbsp; The configure script does warn about the version I am
white-rabbit qemu-neo1973 # gcc-config -l<br>
&nbsp;[1] x86_64-pc-linux-gnu-3.3.6<br>
&nbsp;[2] x86_64-pc-linux-gnu-4.1.2<br>
&nbsp;[3] x86_64-pc-linux-gnu-4.2.0 *<br>
<blockquote cite="mid:20070728185434.569c7acd.henryk@openmoko.org"
  <pre wrap=""></pre>
  <blockquote type="cite">
    <pre wrap="">Nelson Castillo wrote:
    <blockquote type="cite">
      <pre wrap="">Also the developer version?
I have the "libsdl1.2-dev" package in my Debian sid system.
  <pre wrap=""><!---->
Note that the usual notion of "developer packages" does not apply to
Gentoo systems, since all packages are built from source by default all
necessary files to compile against packages are always installed. So,
just installing libsdl is enough.

Thanks for your help.<br>