Hi all,<br><br>I managed to build OpenMoko with MokoMakefile for hx4700 (make setup, change machine to hx4700 in local.conf, make openmoko-devel-image, all went fine).<br>Then I tried to run it.<br>I lauched the kernel with haret, and booted from an ext2 256 MB SD card (a rootdelay option is needed on the kernel command line)
<br><br>So, this gives me a wince-openmoko dual boot :)<br><br>With the 624 MHz pxa270, the speed is fine, kinetic scolling works like a charm, and the whole UI is very reactive :)<br><br>but...<br><br>The problem is, hx4700 has no GSM modem, while openmoko keeps searching for a network.
<br>So I get a full list of status messages at the bottom of the window, that are very annoying. Do you have any idea to remove them? I tried to stop /etc/init.d/gsmd, but it&#39;s not running. I guess I have to stop a gsm status applet, but I don&#39;t know how to do this.
<br>Here is an example: <a href="http://www.yaronet.com/mirari/BQ69">http://www.yaronet.com/mirari/BQ69</a> : &quot;Not searching&quot; blocks displayed at the bottom of the screen.<br><br>Do you have any idea on how to map the hx4700 power button to the openmoko shutdown/suspend command, so that I can save battery life? I&#39;ll ask questions on the handhelds-hx4700-port mailing list too, but I need to know how buttons are managed in OM before I ask them how to achieve this !
<br><br>Ah, last problem (and a minor one), at boot up I see on the fb console that some jffs2 mount operation is not happy with my flash (of course, it&#39;s full of wince and not jffs2 :) ) . I guess this is an init script trying to mount some inexistent partition. Can I disable this?
<br>Here is the &quot;screenshoot&quot;: <a href="http://www.yaronet.com/mirari/1RMS">http://www.yaronet.com/mirari/1RMS</a><br>Cowardly refusing to erase blocks... fine, I didn&#39;t loose my wince image :D<br><br><br>Thanks!
<br clear="all"><br>-- <br>S├ębastien LORQUET