Besides removing, or commenting out, the wlan0 configuration what else is needed to switch eth0 back to being for the wireless instead of wireless?  After setting up wpa_supplicant and making the change I get an error about how eth0 No such device, I can post any needed config files to help figure out what I am doing wrong.