Compiling epdfview for Om2008.8

Sjors Provoost sjors at
Sun Aug 10 09:27:50 CEST 2008

On Sun, Aug 10, 2008 at 2:06 PM, Sjors Provoost <sjors at> wrote:
> Hi there,
> I am trying to build and install a PDF reader and Epdfview [0] seemed
> like a good choice.
> Someone has provided an epdfview binary [1], but it does not seem to
> work on the om2008.8 stack [2]. So I decided to try and recompile it.

Probably related: I found a more recent version here:

But trying to install it yields some nasty dependency errors. It seems
to insist om some very recent versions of libraries. I was not able to
find all of them:

opk install libfreetype6_2.3.6-r0_armv4t.ipk
opkg install libpoppler3_0.8.4-r0_armv4t.ipk
opkg install poppler_0.8.4-r0_armv4t.ipk

opkg install epdfview_0.1.6-r3_armv4t.ipk

The last command returns:
 * ERROR: Cannot satisfy the following dependencies for libpoppler-glib3:
libglib-2.0-0 (>= 2.16.4) *  gtk+ (>= 2.12.11) *  libcairo2 (>= 1.6.4)
*  libpoppler-glib3 (>= 0.8.4)

I can't find this bleeding edge version of libglib-2.0-0. I have not
tried gtk+ and libcairo2. The libpoppler-glib3 has the same
gtk+ (>= 2.12.11) *  libglib-2.0-0 (>= 2.16.4) *  libcairo2 (>= 1.6.4) *


More information about the devel mailing list