Openmoko Bug #1765: No pin-dialog appears after boot, so no gsm is working in 2008.8

Openmoko Public Trac bugs at
Mon Aug 11 22:43:10 CEST 2008

#1765: No pin-dialog appears after boot, so no gsm is working in 2008.8
 Reporter:  Rorschach  |        Owner:  openmoko-devel
     Type:  defect     |       Status:  closed        
 Priority:  highest    |    Milestone:                
Component:  Qtopia     |      Version:  OM-2008.08    
 Severity:  critical   |   Resolution:  worksforme    
 Keywords:             |     Blocking:                
Blockedby:             |  

Comment(by apm):

 This shouldn't be in a bug tracker, but I must say I've never experienced
 so disappointing a behaviour when I've spent time providing debug data.

 Just for the record, I'm not here to keep this ticket open, I'm here to
 help provide data until I can see the problem has been diagnosed and
 bottom line is that you closed the bug report with a wrong and arrogant

 Replying to [comment:41 zecke]:
 > Come on. Instead of actually fixing any bug and moving packages to
 .testing I'm busy with
 > helping people to use a bugtracker... (seen globally on all incoming

 This is insane. You're not learning me anything. I do this every day, just
 from your point of view, and I never tell a reporter to get lost with a
 claim that he's running unsupported software, when he is not.

 > Replying to [comment:37 apm]:
 > > Oh... I just discovered: Incoming calls work, but using the dialer to
 call out still says: "No phone call is possible. Reason GSM phone is not
 registred, No network".
 > Yes, we at least have four reports for that. I have witnessed this as
 well.. I have done a fix, but I'm not able to put a potential fix for that
 into .testing as I'm completely busy with assisting people to use a

 Well - then that was what you should have written as diganose.

 > > I'm reopening this, and please take it serious this time. WE DO NOT
 RUN gsmd
 > At least one user did and I was referring to the log message.

 Yes, but a lot of us wasn't.

 > See, I acknowledge there is an issue. There is no doubt that there is an
 issue. But there is no way I can "solve" what this bug report has been
 turned in. I can not set it to "in_testing" as there is no way QA can
 verify that all the mentioned issues have been fixed. So the best thing I
 can do is to close this bug, and open one bug for one issue mentioned, or
 rely on people doing that. Reopening the bug does not change anything but
 keeps me away from putting bugfixes into .testing.

 But you don't close a bug report by telling people the reason for their
 trouble is something they know and can prove is false.

 > > Symptoms are:
 > > * PIN dialog does not appear after boot!
 > > * It can appear later - for me it sometimes work to restart X
 > > * When it appears it seems to take the PIN correctly
 > > * But afterwards, there's no outgoing GSM calls. (for me incoming
 calls work though)
 > This is all related to the QAtChat (see my 1st vs 2nd) and highly
 dependent on timing. So by restarting, or killing qpe, or changing configs
 can change it. See the last five commits in;a=summary


 > > * However... GSM has been seens to start working after waiting >30
 > Random luck. I think the scanning of external media is just wasting
 power but is not blocking anything inside Qtopia.

 Hmm.. it seems pretty consistant though, that once it has started to work
 it work.

 > Please keep that bug closed, that does not mean there is no issue, but
 we engineers have to have a good signal noise ratio to do our work and
 sadly we really head to a bad direction with this bugtracker.

 Sure I'll keep it close. Now I know that this problem is diagnosed. ...
 see the difference?
 Your S/N ration can be kept down by not giving people bogus explanations.
 Write that you suspect this is a duplicate. Convince people that you're on
 top of it. Don't tell people falsehood - it only gives the impression that
 you don't know what your're talking about which will achieve the exact
 opposite of what you want.

 > Like in the two closing attempts. Your options are:
 >    - File a bug for 1st (no one did that)
 >    - File a bug for 2nd (the initial reporter did)

 No reason - now I know you're on top of it.

Ticket URL: <> <>
openmoko trac

More information about the devel mailing list