Mokomakefile adding new packages?

Jim Morris ml at
Thu Aug 14 00:59:21 CEST 2008

Can someone please answer this question on the Wiki?

I have tried in vain to add a new package to the openembedded packages section, but when I do

 > make build-package-mynewpackage

I get an error about it not existing.

Some other info that would be useful is the "correct" way to add a new version of a package.

I recently got ruby 1.8.6 built, but I had to nuke the 1.8.5 version, rather than having both 
available, it worked but I still get warnings about "not preferred version".

I know these are OE questions, but the docs on OE don't cover these issues either.


Jim Morris,

More information about the devel mailing list