Openmoko Bug #1822: 2008.8 doesn't wake on alarm

Openmoko Public Trac bugs at
Sat Aug 16 00:18:19 CEST 2008

#1822: 2008.8 doesn't wake on alarm
 Reporter:  madjo    |        Owner:  openmoko-devel
     Type:  defect   |       Status:  new           
 Priority:  normal   |    Milestone:                
Component:  unknown  |      Version:  OM-2008.08    
 Severity:  normal   |   Resolution:                
 Keywords:           |     Blocking:                
Blockedby:           |  

Comment(by madjo):

 My situation
 and no I don't have a testcase for it, but it's easy to reproduce (since
 it's constant for me)

 1) time is set correctly. Currently the phone displays 0.12
 2) timezone is set to Amsterdam (is that relevant, is the wake-on-alarm
 dependent on timezones?)
 3) alarm is set to 06.30 (but set it to whatever you like or need to
 reproduce this quickly)
 4) suspend is set to 30 sec
 5) date says: "Sat Aug 16 00:12;30 CEST 2008"
 6) Yes, atd is running.

 Close the settings screen, so that you're back on the home screen (set to
 Now let the phone go to sleep and wait till the alarm time rolls by.
 On my phone nothing happens, until I turn the phone back on. Only then the
 alarm sounds, and the screen is showing.

 Again, the bug is that the device does not wake on alarm, when the alarm
 should go off. So in my case, I expected the device to wake up at 6.30 in
 the morning. Yet it didn't. but when I turned it on myself at 7.00, it
 sounded the chime, and it showed the alarm screen.

Ticket URL: <> <>
openmoko trac

More information about the devel mailing list