Compiling Qt-program for Openmoko2008.8 stack

Holger Freyther zecke at
Sat Aug 16 23:42:05 CEST 2008

On Saturday 16 August 2008 14:21:52 Proton wrote:
> Hi there!
> I'm trying to compile the simplest Qt-program for the 2008.8 stack
> but it doesn't seem to work. I've been trying for some weeks now.
> I asked in several openmoko forums and IRC-channels but it doesn't
> seem to be anyone who wants to do the same.
> So please, could somebody skilled tell me what to do to get this working?
> I'm desperate. :(

You will have to get OE, the org.openmoko.asu.stable branch, build qt4-x11, 
and use the resulting packages, or build your app within OE too (see qsvn as 
a really simple qmake based application). I recently tried building qt4-x11 
and it worked and should bring you what you will need.

Sadly the Qtopia buildsystem does not allow to use the system Qt libraries 
which brings us this mess we are in. So even if Qt is installed on the device 
we can not provide any headers as there is no working make target that would 
install the headers and support tools somewhere....


More information about the devel mailing list