Openmoko Bug #2146: Freerunner will not charge when booted from USB (git andy-tracking)

Openmoko Public Trac bugs at
Tue Dec 2 09:54:20 CET 2008

#2146: Freerunner will not charge when booted from USB (git andy-tracking)
    Reporter:  nicolas.dufresne  |        Owner:  openmoko-devel
        Type:  defect            |       Status:  closed        
    Priority:  normal            |    Milestone:                
   Component:  unknown           |      Version:  unspecified   
    Severity:  normal            |   Resolution:  fixed         
    Keywords:                    |     Haspatch:  0             
   Blockedby:                    |    Estimated:                
 Patchreview:                    |     Blocking:                
Reproducible:                    |  
Changes (by andy):

  * status:  new => closed
  * resolution:  => fixed


 Replying to [comment:5 nicolas.dufresne]:
 > Ok, I found what I did wrong in my first test. I've confirmed that now
 the Freerunner is charging, but there is still a small issue, status still
 display Discharging and online 0. They seem not to be updated. Note that
 this fixed the health field (which was displaying Unknown before).


 The display status issue is probably due to /sys breakage on new kernels.

 I noticed that somewhere along the line (I thing Sean McNeil's android
 stuff) we are now completely stood off from real HDQ access in the
 power_supply stuff, instead it is polling at 30s intervals or so and
 everything seems to be using the cached copies, that can also impact
 display status maybe.

Ticket URL: <> <>
openmoko trac

More information about the devel mailing list