Unable to modify U-boot splash

ramsarvan pl_ram2003 at yahoo.com
Sat Dec 27 03:28:57 CET 2008

Hi Werner,

Thanks for the reply.
>This is strange. When I try this image (*), I get an output of
>17216 bytes after compression.

Used the perl script you mentioned and I am now getting the same 17216 
bytes after compression.

So, I have given the following command in the U-Boot NOR Flash mode,

setenv splashimage nand read.e 0x32000000 splash 0x4340\; unzip 0x32000000
0x33d00000 0x96000

0x4340 => 17216.

But still I am not getting the splash image and I m seeing the words
poweroff at the top left corner.

Any idea?


Werner Almesberger wrote:
> ramsarvan wrote:
>> 1) Downloaded the perl script from
>> http://svn.openmoko.org/developers/werner/splash/imghs.pl
> Oh dear, there you found something really ancient. It still works,
> but the current version is here:
> http://svn.openmoko.org/trunk/src/host/splash/
>> 7) ls -l gives the filesize as 2456 which is 0x0998 (< 0x5000)
>> -rw-r--r-- 1 ram ram  2456 2008-12-26 23:57 splash.gz
> This is strange. When I try this image (*), I get an output of
> 17216 bytes after compression.
> (*) http://wiki.openmoko.org/images/c/c2/System_boot.png
>> setenv splashimage nand read.e 0x32000000 splash 0x1000\; unzip
>> 0x32000000
>> 0x33d00000 0x96000
> 0x33d00000 is the framebuffer address of GTA01. For GTA02, it would
> be 0x8800000.
> - Werner
> _______________________________________________
> devel mailing list
> devel at lists.openmoko.org
> https://lists.openmoko.org/mailman/listinfo/devel

View this message in context: http://n2.nabble.com/Unable-to-modify-U-boot-splash-tp1914477p1966917.html
Sent from the Openmoko Devel mailing list archive at Nabble.com.

More information about the devel mailing list