Errors compiling with toolchain

Steven ** montgoss at
Sat Jul 19 18:00:05 CEST 2008

I think these errors are generic, even though I get them when trying
to compile openmoko-panel-alarm (since I don't see an ipkg available).

When I run om-conf I get the following errors:
 checking for GTK... configure: error: Package requirements
(gtkmm-2.4 >= 2.8) were not met:

 Package pthread-stubs was not found in the pkg-config search path.
 Perhaps you should add the directory containing `pthread-stubs.pc'
to the PKG_CONFIG_PATH environment variable
 Package 'pthread-stubs', required by 'XCB', not found

I think my system has a newer version of gtkmm, but om-conf is using
the toolchain's version.  Or am I misunderstanding?  How do I fix
that?  Same for pthread-stubs.  It's installed on my system.

Any help would be greatly appreciated.  I use my cellphone as my alarm
and really want on working on my FreeRunner.


More information about the devel mailing list