Openmoko Bug #1678: XServer crashed after Update

Openmoko Public Trac bugs at
Mon Jul 28 22:30:14 CEST 2008

#1678: XServer crashed after Update
 Reporter:  morphis  |       Owner:  openmoko-devel
     Type:  defect   |      Status:  new           
 Priority:  highest  |   Milestone:  ASU           
Component:  unknown  |     Version:  GTA02v5       
 Severity:  normal   |    Keywords:                
 Blocking:           |   Blockedby:                
 After updating my FreeRunner this morning from the ASU Repository the
 XServer crashed everytime I boot the FR or I manually restart the XServer
 via ssh. I can repoduce the error with flashing the FR with a pure ASU
 Image from 22. July and updating from the ASU Repository.

 I attached the XServer-Log.

 root at om-gta02:/etc/X11/Xsession.d# cat /var/tmp/x.log

 _XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
 _XSERVTransOpen: transport open failed for inet6/om-gta02:0
 _XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6
 (II) verbosity set to 5
 Using GLAMO 3362 card
 (II) Screen: 16/16 depth/bpp
 (II) vram size:4194304, onscreen vram size:614400, offscreen vram
 (II) initialising offscreen pixmaps
 Extended Input Devices not yet supported. Impelement it at line 637 in
 D-BUS per-session daemon address is: unix:abstract=/tmp/dbus-
 [settings daemon] Forking. run with -n to prevent fork
 enlightenment: symbol lookup error: enlightenment: undefined symbol:
 run-parts: /etc/X11/Xsession.d/90xXWindowManager exited with code 127

 waiting for X server to shut down FreeFontPath: FPE "built-ins" refcount
 is 2, should be 1; fixing.

Ticket URL: <> <>
openmoko trac

More information about the devel mailing list