Calypso firmware update (work in progress)

Joel Newkirk freerunner at
Sun Nov 16 07:59:30 CET 2008

On Sun, 16 Nov 2008 13:37:11 +0800, Joerg Reisenweber <joerg at>
> Am So  16. November 2008 schrieb Joel Newkirk:
>> On Sun, 16 Nov 2008 11:13:41 +0800, Joerg Reisenweber

>> > You say you didn't see this problem at all with your previous device,
> and
>> > now 
>> > with the replacement it shows all the time?
>> > Would be a great hint to find more details on this nasty #1024.
>> > cheers
>> > jOERG
>> That's correct.  On V5 hardware (first retail run, ordered from OM store
>> early July) the GSM was fine.  Since I received V6 hardware after
> warranty
>> exchange it loses GSM constantly, missing calls in the process. Apart

> first of all it would be of interest to find out about exact serial# and 
> GSM-FW revision of (your current and) former device, so we could possibly

> trace back the manufacturing process and scrutinize the logs, as well as 
> FW-version etc.
> Can you give any more details (pointer to ticket, reseller, dunno what) 
> please.
> Did you run the tests with same kernel and rootfs on both devices, and
> still 
> different results for GSM?
> Which SIM/provider are you using? 
> Regards

Current unit: serial 8A8705440 date code 20080804.  DBus query tells me
"GSM: gsm_ac_gp_fd_pu_em_cph_ds_vc_cal35_ri_36_amd8_ts0-Moko8" - is there
any further ID of firmware possible/needed?

Original unit I don't know, I have a photo somewhere of the serial number
sticker that I can dig up. Date code was 20080620.  I don't have firmware
data on it.

Original purchase from in early/mid-July, sent back
under RMA# RT3433-R on August 27th, replacement received Sept 11th was also
a datecode 20080620 V5 unit, which was subsequently replaced under RMA #
RT3433-R2 sent back Sept 24th, replacement received Oct 3rd.  I don't think
I have any further info on the middle unit, the second replacement (Oct3)
is my present unit.  Per Tony Tu the first one was supposed to become
involved in investigating why the touchscreen scratched so easily with the
stylus.  (it was sans screen protector for the first couple days and got an
ugly scratch from dragging the damned unlock in 2007.2, since which I've
never touched a FR touchscreen without a sturdy screen protector in place)

To be honest, I've flashed and reflashed so often that I don't even know
what kernel and rootfs if any may have been common to the two units.  I
don't think I ever had the problem whatsoever with the V5 units - certainly
I never noticed it.  At the time I RMA'ed the original, 2008.8 was the 'new
thing', I don't think I ever flashed anything but that onto it, and I think
2008.9 was the first I flashed onto the V6, immediately opkg upgrade'd. 
I've since flashed FSO, SHR and Raster images (as well as 2008.x and FDOM)
at various times in each of their revisions, sometimes all of them within a
single day. (testing networking fixes or ipk dependancies)

Provider is T-Mobile in US - I'm in North Carolina 2 years now, and until a
couple months ago that meant permanent roaming on Suncom and Cingular/ATT,
though T-Mo now own Suncom and have almost finished absorbing them - towers
still ID as Suncom.  The SIM is probably 7 years old now, I swapped it out
about 13 months after first getting T-Mo service.  (I've been happy with
their service, though not always the phones nor customer service, and
they've rewarded my loyalty with double minutes in my plan, and
grandfathered me with a $20 unlimited data plan they haven't offered for at
least 4 years, since pre-EDGE days - the internet3 'VPN' plan)


More information about the devel mailing list