Openmoko Bug #1841: white screen of death (WSOD) after resume

Openmoko Public Trac bugs at
Sat Nov 22 23:35:34 CET 2008

#1841: white screen of death (WSOD) after resume
    Reporter:  Rorschach    |        Owner:  openmoko-devel
        Type:  defect       |       Status:  new           
    Priority:  highest      |    Milestone:                
   Component:  unknown      |      Version:  GTA02v5       
    Severity:  critical     |   Resolution:                
    Keywords:  wsod,resume  |     Haspatch:  0             
   Blockedby:               |    Estimated:                
 Patchreview:               |     Blocking:                
Reproducible:  always       |  

Comment(by joerg):

 Replying to [comment:59 nicolas.dufresne]:
 > Warming the device before resume worked. No WSOD. I hope this
 information will help.
 > I've also noticed that according to the spec it take a minimum 250 ms
 for the LCD to wake from suspend.

 Actually this test might be very helpful on locating the problem.
 The startup behaviour could differ depending on temperature.

 We should check the code, if the situation mentioned by you really applies
 to LCD-resume, and for a sufficient delay after resume of LCD.

 Yesterday Tony put a FR into the fridge, but wasn't able to reproduce the
 WSOD. Seems we aren't able to create WSOD situation here in TPE, at least
 up to now.
 I will extend the search next days, as soon as I find a fridge in the
 office where we could freeze all the phones I can "borrow" for a few

 @Andy: what would you suggest to probe/meassure/test if we can find a FR
 with WSOD. I'd like to help on this issue.


Ticket URL: <> <>
openmoko trac

More information about the devel mailing list