OE, bitbake and dependencies

Alastair Johnson alastair at truebox.co.uk
Wed Oct 8 17:09:46 CEST 2008

I'm trying to build linphone in the fso-testing tree created by the FSO 
Makefile and I'm having dependency issues. linphone-1.6.0 requires 
libosip2-2.2.2 to build cleanly, and won't build with libosip2-3.1.0 but 
bitbake insists on using 3.1.0. Following Gentoo practice I tried using 
  <=libosip2-2.2.2 in DEPENDS and RDEPENDS but this just gives me:

Missing or unbuildable dependency chain was: ['linphone', 

I may just be using the wrong combination of keywords but I couldn't 
find any documentation on how to specify version dependencies. Have I 
missed it, or is it just not possible with bitbake?

More information about the devel mailing list