Openmoko Bug #1852: Can't register on GSM Network

Openmoko Public Trac bugs at
Tue Sep 2 06:50:54 CEST 2008

#1852: Can't register on GSM Network
    Reporter:  jonquark  |        Owner:  openmoko-devel
        Type:  defect    |       Status:  assigned      
    Priority:  normal    |    Milestone:  Om2008.9      
   Component:  Distro    |      Version:  GTA02v6       
    Severity:  normal    |   Resolution:                
    Keywords:            |    Blockedby:                
Reproducible:  always    |     Blocking:                

Comment(by erin_yueh):

 Replying to [comment:8 jonquark]:
 > Replying to [comment:6 erin_yueh]:
 > > 1. can these O2 sim cards register to GSM network from other phone
 > Sorry - I should have stated that all these cards work fine in other
 (2G) phones, including my
 > Nokia 6230i and my wife's Motorola.
 > > since you get error code 13, it looks like SIM card problem. Are these
 3 cards all failed? and > get the same error code?
 > all the cards behave in the same manner, I'm guessing it's a problem
 with the modem firmware?
 > It sounds a lot like #666 (except for 2G SIMs). All the SIMs I have look
 like the not working
 > SIM labelled "O2 Germany" on:
 > (i.e. the side "terminals" on the chip are separated by more than just a
 thin line which
 > is what the working SIM card I have (Vodaphone UK) looks like.
 > Here is the output from the AT Commands you requested:
 > RSTR=`+CGSN: 354651011631720'
 > AT+CREG=2
 > STR=`AT+CREG=2'
 > RSTR=`OK'
 > AT+COPS=0
 > STR=`AT+COPS=0'
 > cme error: 3
 your firmware version is already the latest one and with a valid imei
 when you tried to register to the network, you got a cme error 3.
 +CME ERROR: 3 means operation not allowed

 graeme is living in UK and he can use O2 UK sim card without problem. I am
 sorry that you cannot use it as well. Would you like to replace with a new
 SIM card from O2? sometimes it's really a SIM card problem.

Ticket URL: <> <>
openmoko trac

More information about the devel mailing list