Openmoko Bug #1967: [kernel] image and modules not in sync

Openmoko Public Trac bugs at
Sat Sep 6 10:13:10 CEST 2008

#1967: [kernel] image and modules not in sync
 Reporter:  vnevoa   |          Owner:  openmoko-devel
     Type:  defect   |         Status:  new           
 Priority:  highest  |      Milestone:                
Component:  unknown  |        Version:  Om2008.8      
 Severity:  blocker  |       Keywords:  kernel modules
Blockedby:           |   Reproducible:  always        
 Blocking:           |  
 There are kernel modules in the file system that are not loadable because
 they are already built in. If the modules are built-in, they should not be
 present in the filesystem, IMHO.

 This confuses the hell out of users that are trying to follow the wiki
 howtos (BT networking, for example), and also delays the bootup and fills
 the logs with false error messages about failed module loadings.

 Reproducing: "modprobe bnep"

 My software is:
 uname -a = "Linux om-gta02 2.6.24 #1 PREEMPT Wed Sep 3 19:01:18 CST 2008
 armv4tl unknown"

 My opkg feeds are:
 src/gz daily-Multiverse
 src/gz om-dev-all
 src/gz om-dev-armv4t
 src/gz om-dev-om-gta02
 src/gz testing-all
 src/gz testing-armv4t
 src/gz testing-om-gta02

 Failed modules that I know of:
 bnep, bluetooth, l2cap

 Please clean up the built-in modules from the fs images on the
 downloads server so they are consistent with the given kernel.
 Thank you! Keep up the good work.

Ticket URL: <> <>
openmoko trac

More information about the devel mailing list