Openmoko Bug #1983: eth0 doesn't exist / Oops during bootup

Openmoko Public Trac bugs at
Thu Sep 11 13:09:38 CEST 2008

#1983: eth0 doesn't exist / Oops during bootup
    Reporter:  Weiss        |        Owner:  openmoko-devel
        Type:  defect       |       Status:  new           
    Priority:  normal       |    Milestone:                
   Component:  unknown      |      Version:                
    Severity:  normal       |   Resolution:                
    Keywords:  wifi kernel  |    Blockedby:                
Reproducible:  always       |     Blocking:                

Comment(by Weiss):

 Thanks for the reply again.  I've obtained a full 'dmesg' trace (dmesg-
 beforejiggling.log) which shows the timeouts from the start with nothing
 else which looks relevant to me.  I opened the case and checked the WLAN
 module, but it seems nicely seated and is very firmly stuck in place.  I
 tried to wiggle it around a little but it really wasn't moving more than a
 fraction of a millimetre.

 After poking around, the timeouts in dmesg seemed to have gone (dmesg-
 afterjiggling.log), but there was still no wifi (same 'no such device'
 errors).  On a subsequent bootup, the errors had returned (dmesg-
 afterjiggling-withtimeouts.log).  I'm afraid I couldn't swear to the
 timeout messages not having been intermittent before the poking around - I
 wasn't watching too closely until I began to realise that the messages
 during bootup could be related to the wifi problems.

Ticket URL: <> <>
openmoko trac

More information about the devel mailing list