Building an ipk file using control file

Fernando fernando at
Sun Sep 7 23:45:17 CEST 2008


I was able to create an ipk file for project osip[1].

But it seems that the control file is not taken into account. Once installed
on FreeRunner, here is output of "opkg list_installed osip" and "okpg info
osip" commands :
root at om-gta02:~# opkg list_installed osip
osip - 0.1b - 
root at om-gta02:~# opkg info osip
Package: osip
Version: 0.1b
Status: install user installed
Architecture: armv4t
Installed-Time: 1220694199

And here is my control file:
Package: osip
Version: 0.1b
Section: misc
Priority: optional
Maintainer: Fernando <fernando at>
Architecture: armv4t
Description: Osip is a SIP client to place phone calls on SIP networks.
	It needs an internet connection.

I tried building package using om-make-ipkg and ipkg-build [2], but both
methods give the same result: control file does not seems to be used...

Is this a known bug ? Do you have any idea on how to build better ipk files ?

[2] complete directory used with ipkg-build command can be found here:

More information about the devel mailing list