Getting Neo1973 running again.

Svetoslav Trochev sal_electronics at
Sun Aug 16 02:43:54 CEST 2009

Thank you very much Lev, your and Paul's replies help me to get my
Neo1973 running again.
Currently my Neo1973 is running:
kernel: uImage-om-gta01-latest.bin (I believe to be
rootfs: shr-lite-glibc-ipk--20090808-om-gta01.rootfs.jffs2
u-boot: 1.3.1 see below.

Currently I am having problem with GSM. The first time started SHR it
work and I was able to make outgoing and receive incoming calls. After I
power-off the device and power it back on the GSM was not connecting to
the AT&T any more. I power-off the phone, pull the battery out and hold
[power] button for 10s. Then I put the battery back in, power-on the
phone and GSM worked again until I try to suspend the device. Now I
remember some discussions about this problem and if my memory is not
playing trick on me I believe there is update for the GSM firmware, but
I am having problem locating the instructions on the wiki. So my
question to everyone am I correct or I need to look some where else to
get my GSM working correctly?

Lev M wrote:
> Hi.
> I do not have all the answers, but I spent a few hoers last night trying
> to get the latest SHR unstable running on my Neo 1973 so it will be in
> sync with my Freerunner (one is used for development and another as
> primary phone).
> Here is what I learned from the experience, hope it will be helpful:
> 1. The 1.2 u-boot which comes standard on 1973 works fine with latest
> dfu-util (at least I never had trouble with it and I flash the device
> quite often).
> 2. It is however completely unable to boot from SD neither using FAT nor
> EXT2 for kernel partition.
> 3. Even after updating the u-boot you will still need to tweak it's
> environment variables to get it to boot from SD (they are not changed by
> the upgrade)
> Now, if you want to use SHR on the 1973 you have 2 choices:
> A) use the shr-lite image which has a few things missing but is small
> enough to fit on the internal memory.
> B) put the regular SHR on the microSD as described in the WiKi and fix
> the u-boot.
> I went with option B after finding option A to be too poor in apps.
> (Actually I tried A a long time ago so it might be better now).
> For me it was a somewhat hard decision as I do not have a debug board.
> Fortunately, it worked out OK.
> I used the image from this address:
> You have to mind the hardware  version, mine was Bv4. You can see this
> on the sticker behind the battery or when you connect with dfu-util.
> Speaking of dfu-util, most mainstream distros have it packaged now. For
> example I use Ubuntu and just installed it using apt-get.
> For more information look here:
> Full instruction for flashing the 1973 live here:
> But all I had to do was: sudo dfu-util -a u-boot -D -R
> name-of-image-file.bin
I had to update my u-boot to version 1.3.1 because version 1.2.0 could
not boot automatically. The old u-boot was able to boot SHR's kernel
only if was going through the boot menu. Otherwise it hang on 'Openmoko'
splash screen and never passed the control over to the kernel. After the
upgrade to version 1.3.1 auto boot works every time.
I am using GTA01BV4 also and use the image:
> Little curiosity: I did not noticed I missed -a at first. dfu-util
> seemed to indicate flashing went OK, but when I rebooted the device the
> u-boot version has not changed. It was apparently downloaded to RAM and
> not written to NAND.
> I went through this 4 times with 2 different images before noticing the
> error.
> To change the environment vars you will need to connect with the cu
> utility. Again, it is most likely in you distro's repos.
> cu -l /dev/ttyACM0
> You can read the vars with printenv (or type help to get the full
> command list)
> setenv name value
> to set a variable. You will need to escape ; and $ with \
> Use saveenv to permanently store changes to NAND.
> Basically these instructions are listed on the "Booting from SD" page,
> but they seem a bit sparse for someone like me who does not know much
> about kernel parameters.
> So, I used the original value of "Boot from SD" entry with a couple of
> small changes rather then writing from scratch.
> For some reason, the bootloader console had trouble accepting more then
> 2 lines of text so I had to split the vars.
> setenv sd_bootargs root=/dev/mmcblk0p2 rootdelay=5
> console=ttySAC0,115200 console=tty0 loglevel=8 rootfstype=ext2 ro
> setenv menu_4 Boot from MicroSD (ext2): setenv \${sd_bootargs}\;
> mmcinit\; ext2load mmc 0 0x32000000 /boot/${sd_image_name}; bootm 0x32000000
> note that the second setenv in the second line (after (ext2):) is
> actually part of the value of menu_4.
> Another thing to note with this setup is that it will look for the
> kernel image on the first partition of SD, it should be of type ext2 and
> the path is /boot/uImage
> You can change it to what ever you want, I just went with what was there.
> All this info is of course in the wiki.
> Hope this helps, Good luck!
> Svetoslav Trochev wrote:
>> Hi everybody,
>> I am owner of Neo1973. For many reasons (some Openmoko, other personal )
>> it remainder unused for very long time. I was keeping eye on dev list
>> for while and I see some good trends and I would love to help. The first
>> step would be to become more familiar with the phone. Yesterday I got my
>> self a new working SIM card and made my first call, but the currently
>> install version of the OM2007.x distribution is practically unusable.
>> Based on my limited understanding I thing I should start with SHR
>> distribution. But I would like some check on my assumptions:
>> 1. The FSO distribution will be discontinued in order to allow
>> developers to concentrate on working on the framework.
>> 2. The SHR will become the facto official distribution to use and
>> showcase the FSO framework.
>> 3. From reading mailing list [1] I should use the u-boot on Neo1973.
>> 4. My current version is "U-Boot
>> 1.2.0-moko9_r8_70124c2602ae2d4c5d3dba05b482b482d91548242de8_0_2040 (May
>> 19 2007 - 06:59:48) I don't remember and can't find the wiki page now
>> that it is recommended to upgrade my U-Boot loader in order to support
>> newer version dfu-util and NeoTool. I am not sure that NeoTool will work
>> with Neo1973 at all. (note: I have debug board so if I brick the phone I
>> should able to recover it, Right?! )
>> 5. I am having trouble locating recommended versions for:
>>     5.1 U-boot loader for Neo1973
>>     5.2 dfu-util (version that will work with Neo1973)
>>     5.3 NeoTool ( if it works with Neo 1973)
>> 6. My current understanding is that each distribution uses own kernel.
>> Is this correct?
>> 7. Currently SHR is too big to fit on the internal flash memory and
>> should be installed on uSD card. Instructions can be found here: [2]
>> I would appreciate any help I can get.
>> Thank you,
>> SAL-e
>> [1]
>> [2]
>> _______________________________________________
>> devel mailing list
>> devel at
> _______________________________________________
> devel mailing list
> devel at

More information about the devel mailing list