Whats up with downloads.freesmartphone.org?

Rod Whitby rod at whitby.id.au
Fri Jan 2 12:31:15 CET 2009

Erland Lewin wrote:
> 2009/1/2 Rod Whitby <rod at whitby.id.au <mailto:rod at whitby.id.au>>
>     The README on downloads.freesmartphone.org
>     <http://downloads.freesmartphone.org> will point you to the build
>     logs, from where you can determine which OE packages are causing the
>     builds to fail.  Then you can raise bug reports for those failures
>     and when they are all fixed the images will be built again.
> When I go to:
> http://tinderbox.openembedded.net/builders/unstable%40freesmartphone.org/
> and search for om-gta02 builds, there is no log for any build attempts
> since 2008-11-04 21:59:06.481617.

If the gta01 build fails, the gta02 build is not started.  It's the way
to keep FSO honest and building for gta01 owners ;-)

> For om-gta01, it reports a successful build on 2009-01-02, but there I
> don't see any files since after november for the gta01 under
> http://downloads.freesmartphone.org/fso-unstable/

Look closer - linux-openmoko is failing for om-gta01.  See 2009-01-02
09:09:23.234723 for example.  This is causing the failure of gta01
images.  The package-index target always passes - it's just there to
make sure that any packages that do actually build correctly get indexed
for the feed.  But since the image fails the rsync is not done.  I'll
manually push an rsync with the latest packages even though the image fails.

> I'm guessing something is not right with the autobuilder?

The autobuilder is running fine - it's just that linux-openmoko is
broken for om-gta01.

-- Rod

More information about the devel mailing list