andy-tracking (was: Re: updated kernel build how-to, from scratch)

Sander van Grieken sander at
Wed Jan 7 11:32:24 CET 2009

On Tuesday 06 January 2009 11:31:42 Gergely Imreh wrote:
> 2009/1/6 Sander van Grieken <sander at>:
> >>   I was checking out how to compile my own kernel (uImage) for my
> >> GTA02, but run into a few problem while following the wiki - which now
> >> seems seriously out of date. In the end I managed to compile a kernel,
> >> and my Neo boots, though it seems a lot of things won't work.
> >
> > Did you extract the modules onto the rootfs?
> Yeah, they are on. After boot there's the ipv6 module loaded, that's
> all. I tried to compare it with the previous kernel, but so far the
> modules I checked are compiled into the new kernel by default (like
> sound, or wireless...)

On my FR ipv6 and s3c2410_wdt are loaded.

sound and wireless seem to work, haven't tested anything else.

> >> After all this, does the current andy-tracking kernel work properly
> >> for everybody else? Or which version of the userspace programs one
> >> needs to make them work? I think mine somewhere about 2008.9. Having
> >> asked this, I haven't tested it extensively (it took a while to figure
> >> out the previous section, and the compile wasn't that quick on my
> >> Eee....)
> >
> > For FSO, there's a patch to frameworkd to work with the new sysfs nodes :
> >
> >
> >
> > For OM2008.x, I don't know..
> Cheers, I'll check it out. I've seen the changes mentioned on the
> wiki, but wasn't sure how much should would out of the box - since
> _someone_ has to be using the 2.6.28 kernel....

It turns out I didn't have to use the patch. I use openembedded to build 
everything, and the patch mentioned above is already in frameworkd-devel.

In the end I only had to change bitbake's conf/local.conf and include these 
lines to move over to 2.6.28 + comaptible frameworkd:

PREFERRED_PROVIDER_virtual/kernel = "linux-openmoko-devel"
PREFERRED_PROVIDER_frameworkd = "frameworkd-devel"

Of course I also had to change my u-boot environment to load a bigger kernel..

my findings so far with andy-tracking:

- resume seems to work even after a long time (10h) being suspended, but I 
tested this once so far. With 2.6.24 that also worked half of the times I 
tried, so I'm not certain yet this works better with 2.6.28
- wifi seems to be toggled by each suspend/resume cycle. After boot wifi is 
enabled (even though the interface is not marked 'auto' in 
/etc/network/interfaces). After the first suspend cycle it's disabled, the 
next cycle it's enabled again, etc.


More information about the devel mailing list