JTAG communication failure, check connection, JTAG interface, target power etc.

Andy Green andy at openmoko.com
Wed Jan 7 15:30:37 CET 2009

Hash: SHA1

Somebody in the thread at some point said:
| Hi,
| --- On Wed, Jan 7, 2009 at 7:06 PM, Andy Green <andy at openmoko.com> wrote:
| | jtag_speed 0
| |
| | Try increasing this, despite "speed" it actually means "delay".
| |
| | Also, only certain magic libftdi versions work, IIRC 0.8 is good.
| \--
| I tried 4, 8, 20 for jtag_speed, but, I still get the JTAG
| communication failure error messages. The same desktop setup worked
| earlier, so, I am wondering if it could be due to low battery power on
| the FR?
| http://www.mail-archive.com/community@lists.openmoko.org/msg29185.html
| The battery status says 57% when directly connected to the PC and doing:
|   cat /sys/devices/platform/bq27000-battery.0/power_supply/bat/status
| says "Not Charging" on (ASU-200811142247). Is there a minimal X %
| battery status required when connected to the debug board for JTAG to
| function?

Nope, if the processor is running the JTAG should be able to work.

About the charging problem, you might want to try andy-tracking based
kernel, the charging should work reliably there.

- -Andy
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org


More information about the devel mailing list