Python Error <No module named Tkinter>

HackCandy hackhell.candy at
Sat Jan 24 18:36:29 CET 2009

Hello All,

I am pretty much new to Python. I tried  running a script and it 
breaks at the first line itself.

Distro Used : 2008.12
Command Line Used: xinit -- /usr/bin/Xglamo -hide-cursor -fp
Note: The script runs a python script & while running
it gives me the following error.

Traceback (most recent call last):
  File "/home/root/bin/", line 34, in <module>
    from Tkinter import *
ImportError: No module named Tkinter

root at om-gta02:~# ls /usr/bin/python*   <from device>
/usr/bin/python            /usr/bin/python2.5
/usr/bin/python-config     /usr/bin/python2.5-config

root at om-gta02:~# echo $PATH

root at om-gta02:~# echo $LD_LIBRARY_PATH

I tried googling but found only for Desktop issues,
saying Install Python.

Do I have to install something? Or Am I missing
some PATH variables? 

I m clueless. Please help.

- HC
View this message in context:
Sent from the Openmoko Devel mailing list archive at

More information about the devel mailing list