GPS receiver broken (but no SDcard problem)

Paul Fertser fercerpav at
Mon Jun 15 11:37:21 CEST 2009

Alexander Lehner <lehner at> writes:
> Now I'm not sure whether it is 'only' the antenna that is broken, so 
> that I could live with an external antenna or the whole GPS unit is
> dead.

Look at frameworkd.log, it has enough information to say if SoC able
to communicate with the gps chip or not.

> gpspipe -r localhost says:
> $GPGGA,,,,,,0,00,,,,,,,*66
> $GPGSA,A,0,,,,,,,,,,,,,,,*1f
> $GPGSV,1,1,00*79
> $GPRMC,,V,,,,,,,,,*31
> $GPGLL,,,,,,V*06
> $GPVTG,,,,,,,,*52
> ...
> Is this output produced from the GPS chip or from software?

Most probably that's the output of fso-gpsd (gpsd-compatibility
daemon) that communicates with frameworkd using gypsy.

> When I do a 'cat -e /dev/ttySAC1' it returns immediately with no output 
> (/sys/../power_on is '1').

Probably because frameworkd is still running and the port is busy.

> I've tried all the SD/CARD, connector fixes from the Wiki, but this 
> obviously not the reason.

You mean you tried to use pliers to bend the connector a little?

Be free, use free ( software!
mailto:fercerpav at

More information about the devel mailing list