Resolved [NOT!]: Re: GPS receiver broken (but no SDcard problem)

Nikolay Mitev face.mitev at
Wed Jun 17 00:09:17 CEST 2009

Alexander Lehner wrote:
> On Tue, 16 Jun 2009, Timo Juhani Lindfors wrote:
>> Alexander Lehner <lehner at> writes:
>>> There is no visible difference between the working state and the state
>>> where no satelites were seen:e
>> Next time please save the output of stty -F /dev/ttySAC1 -a
Ok, I have the exact same problem. Since I got my freerunner I only got 
GPS working *once*. I always thought it was a SW problem, but now I'm 
starting to think its not. I get rxerr: port ch=0x00, rxs=0x0000000c in 
dmesg, no satellites visible... nothing. This is the output from stty:

stty -F /dev/ttySAC1 -a
speed 9600 baud; rows 24; columns 80;
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = <undef>; 
eol2 = <undef>; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R;
werase = ^W; lnext = ^V; flush = ^O; min = 0; time = 0;
-parenb -parodd cs8 -hupcl -cstopb cread clocal -crtscts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr -icrnl 
-ixon -ixoff -iuclc -ixany -imaxbel
-opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 
vt0 ff0
-isig -icanon -iexten -echo -echoe -echok -echonl -noflsh -xcase -tostop 
-echoprt -echoctl -echoke

btw, I tried the plier thingy with no success at all. Right now I'm 
testing without any sim card or microSD card inserted. What should I try 


P.S. Haven't tried with wine, but beer (and lots of it, btw) doesn't 
help at all.

More information about the devel mailing list