Resolved [NOT!]: Re: GPS receiver broken (but no SDcard problem)

Alexander Lehner lehner at
Wed Jun 17 07:51:01 CEST 2009

On Wed, 17 Jun 2009, Nikolay Mitev wrote:

> Alexander Lehner wrote:
>> On Tue, 16 Jun 2009, Timo Juhani Lindfors wrote:
>>> Alexander Lehner <lehner at> writes:
>>>> There is no visible difference between the working state and the state
>>>> where no satelites were seen:e
>>> Next time please save the output of stty -F /dev/ttySAC1 -a
> Ok, I have the exact same problem. Since I got my freerunner I only got
> GPS working *once*. I always thought it was a SW problem, but now I'm
> starting to think its not. I get rxerr: port ch=0x00, rxs=0x0000000c in
> dmesg, no satellites visible... nothing. This is the output from stty:
> [deleted]
> btw, I tried the plier thingy with no success at all. Right now I'm
> testing without any sim card or microSD card inserted. What should I try
> next?

What image are you using? I experienced this problem only since I have SHR 
(based on FSO) installed. Maybe an coincidence, maybe not.
FSO is using the GPS chip in a different way, and I found some similair 
bug reports that were related to this issue (but are reported to be fixed 

Have you tried different images (Om 2008/9)?


More information about the devel mailing list