[PATCH] Openembedded xorg-server recipe missing requirements

Angus Ainslie nytowl at openmoko.org
Mon Mar 2 21:31:48 CET 2009

On Sun, 2009-03-01 at 16:47 +0100, Jorge Luis Zapata wrote:
> Hi all, in order to compile correctly the xf86-video-glamo we need to 
> change some parameters on the xorg-server 1.4.2-r11 pkg-config file.
> 1. There's no Requirement entry for pixman-1 but xorg-server uses it for 
> building.

Can this be satisfied by adding a DEPENDS to the xorg-xserver recipe ?

> 2. The CFLAGS/LIBS is relative to the sdk var, but it isnt set, i have 
> no idea why, but changing it fixed the compilation of the driver.

Is there a configure option that sets this ? I can then add it to
OE_EXTRA_CONF in the recipe.


More information about the devel mailing list