Flashing qi

Angus Ainslie nytowl at openmoko.org
Thu Mar 5 15:18:46 CET 2009

On Thu, 2009-03-05 at 08:39 +0000, Andy Green wrote:
> Somebody in the thread at some point said:
> | Can anyone shed any light on this problem? I cannot flash the qi from
> | http://downloads.openmoko.org/distro/unstable/NeoFreerunner/ as shown

That's the correct location, the files are just currently broken. It's
on my todo list to fix today.

> | below onto my GTA02v5.  I am able to flash the qi from
> | http://people.openmoko.org/andy/.  However Andy's qi ends up with a
> | Black Screen Of Death after resume of pretty much ANY distro I have tried.
> Unless we recently broke something, it works here.

The version of qi at http://people.openmoko.org/andy/ does have issues.
I didn't get the BSoD. With the 2.6.28-stable kernel I was having
problems with battery charging and sensing.

> | [scott at erik fso]$ ../dfu-util  -R -a u-boot -D
> |
> qi-s3c2442-master-0.0.0+gitr1fc83905fe99da92ff18e6ba671ee339477b1b9e-r0.bin
> It's the wrong file, it should have .udfu suffix for GTA02.

That's the correct file, Andy I sent you an email about it a few days
ago. The recipe is garbling the files somehow. 

> | state(10) = dfuERROR, status(1) = File is not targeted for use by this
> | device
> This typically means the U-Boot header is missing on what you sent, and
> that's the case here I think we find.

I'll remove the current version and post to this thread once I get the
recipe to behave properly.


More information about the devel mailing list