Openmoko Bug #2253: Very high, silent beep when screen in horizontal mode (xrand -3)

Openmoko Public Trac bugs at
Sat Mar 7 13:26:07 CET 2009

#2253: Very high, silent beep when screen in horizontal mode (xrand -3)
 Reporter:  rhk      |          Owner:  openmoko-devel
     Type:  defect   |         Status:  new           
 Priority:  normal   |      Milestone:                
Component:  unknown  |        Version:                
 Severity:  normal   |       Keywords:                
 Haspatch:  0        |      Blockedby:                
Estimated:           |    Patchreview:                
 Blocking:           |   Reproducible:                

Comment(by rhk):

 PaulFert & DocScrutinizer helped me to figure out some details:

 - md5sum /dev/random doesn't effect
 - I'm 27, my ears should be OK but it shouldn't be too high for someone
 with normal hearing
 - pressing the phone or the sreen has no effect (except when touching the
 screen I hear a little lower beep, very silent, stops when I release)
 - illume-theme (dark) vs full white screen has no effect
 - backlight brightness has no effect
 - I can hear it furthen than where my hand reaches. The signal is very
 'well focused' -> when the screen is pointing at me I can hear it, when I
 turn it a bit away it gets quieter
 - trying all 'mute' options in alsamixer had no effect
 - pluggin in the headphone (no alsa state changes, I'd guess) had no
 - filling my ears with beewax is a bad solution
 - running on battery only vs battery+usb has no effect
 - submerging in liquid copper or extra-virgin olive oil prevents me from
 hearing it and eventyally stops the beep too :)

 I'm working on trying newer kernels...

Ticket URL: <> <>
openmoko trac

More information about the devel mailing list