Using blitting via glamo dri via libdri

Rashid rashid at
Mon Jul 26 21:14:42 CEST 2010

hi guys im trying to use hw accelerated blitting in a small game.

I got the latest snapshot from;a=tree;hb=HEAD

And used in the source directory:

om-conf libdrm

checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... 64
checking for working alloca.h... yes
checking for alloca... yes
checking for arm-angstrom-linux-gnueabi-pkg-config... no
checking for pkg-config... /usr/local/openmoko/arm/bin/pkg-config
configure: WARNING: using cross tools not prefixed with host triplet
checking pkg-config is at least version 0.9.0... yes
checking for PTHREADSTUBS... configure: error: Package requirements
(pthread-stubs) were not met:

No package 'pthread-stubs' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables PTHREADSTUBS_CFLAGS
and PTHREADSTUBS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

FATAL: oe_runconf failed

I got the error. Btw. someone knows how to patch easily sdl to use HW
accelerated blitting instead of software blitting?


More information about the devel mailing list